Raspberry Pi: arkOS Cloud (Alpha) installieren

15 Feb
15. Februar 2014

Diese Woche veröffentlichte ich bereits einen Artikel, der meine Eindrücke der aktuellen Version von arkOS darstellte und beschrieb, was arkOS konkret ist. In diesem Artikel möchte ich kurz die ersten Schritte von der Installation bis zur Inbetriebnahme des Systems erklären. Dabei werde ich nicht auf jede Einstellung eingehen, sondern mich nach der Einrichtung des Systems auf die Einrichtung von Owncloud als Beispielsanwendung beschränken. Weitere Bereiche von arkOS könnt ihr ja auch auf eigene Faust erkunden 😉

Voraussetzung: Windows, Linux oder Mac OS X Rechner

Step 1

Zunächst müssen wir den Installer von der arkOS Webseite für unser Betriebssystem herunterladen und öffnen.

Step 2

Im Installer angekommen wählen wir nun Installieren Sie arkOS auf einer SD-Karte. Anschließend wählen wir einen der vorgeschlagenen Download-Server aus. Im darauffolgenden Schritt müssen wir aus der Liste der verfügbaren Speichermedien die SD-Karte auswählen (muss größer als 2GB sein). Wichtig ist hierbei, auch sicher nur die SD-Karte zu wählen, da der angegebene Datenträger formatiert wird! Über einen Klick auf Download/Installation starten wird der arkOS Installer die SD-Karte bespielen, was einige Zeit dauern kann.

Step 3

Die fertige SD-Karte stecken wir nun in den Raspberry Pi und hängen diesen an den Strom. Ein bis zwei Minuten später können wir im Browser http://arkOS:8000 (arkOS durch IP-Adresse/DynDNS Domain des Raspberry Pis ersetzen) aufrufen.

Wenn du die IP-Adresse des Raspberry Pis nicht kennst, kannst du auch erneut den arkOS Installer öffnen und in diesem auf Das Netzwerk nach arkOS Geräten durchsuchen klicken. Mit einem weiteren Klick auf Scannen wird die Software das Netzwerk durchsuchen und ausgeben, unter welcher IP-Adresse der Raspberry Pi mit arkOS verfügbar ist. Unter Mac OS X muss momentan, damit dies funktioniert, nmap installiert sein (bspw. über Brew installieren).

Step 4

Im Webinterface angekommen melden wir uns mit dem Benutzer admin und dem Passwort admin an. Daraufhin gelangen wir auf die Willkommensseite von arkOS, wo wir mittels eines Klicks auf OK den Setup-Prozess anstoßen. In diesem folgen wir den Anweisungen.

Hierbei setzen wir im dritten Schritt bei Expand arkOS to fit SD card? den Haken, sodass arkOS die ganze SD-Karte für sich beansprucht. Bei den Anwendungen/Plugins zum Installieren sollten wir auf jeden Fall Basic Website und Database – MariaDB aktivieren. Für das Beispiel in den kommenden Schritten benötigen wir auch noch ownCloud.

Step 5

Zum Abschluss müssen wir den Raspberry Pi einmal neustarten, indem wir rechts oben auf den Power Button klicken und dort Restart System anwählen.

Und das wars schon! Jetzt können wir arkOS in dessen Vielfalt erkunden. Im Folgenden, da dies etwas versteckt ist, noch als Beispiel, wie man Owncloud installiert.

Step 6

Zunächst müssen wir für die Datenbank MariaDB ein Passwort vergeben. Dies können wir bewerkstelligen, indem wir in der Sidebar auf der linken Seite auf Databases klicken. Dort müssen wir dann die Tab Settings anwählen und über Click to change ein Passwort setzen.

Step 7

Nun können wir erneut in der linken Sidebar Websites ansteuern. Dort klicken wir dann auf Add website und im aufgehenden Fenster können wir ownCloud wählen. In dem Feld Address muss man die IP-Adresse oder DynDNS Domain, die verwendet werden soll, eingetragen werden. Des Weiteren müssen wir unter der Tab App Settings noch einen Benutzernamen mit Passwort für den Owncloud Admin-Benutzer definieren.

Genesis (Weboberfläche von arkOS) wird anschließend Owncloud installieren, was ein paar Minuten dauern kann. Anschließend können wir Owncloud über http://IP/ (IP durch IP-Adresse/DynDNS Domain des Raspberry Pis ersetzen) aufrufen.

Nun solltest du anhand von Owncloud das Grundprinzip von arkOS zur Installation einer Webapp verstanden haben. Viel Erfolg bei der Nutzung. Und bitte denk dran: arkOS ist momentan noch in einer Alpha-Phase, sodass es noch häufiger zu Fehlern kommen kann!

Diese Anleitung wurde am 21. April 2014 überarbeitet.

Dir hat der Artikel gefallen?
Teile ihn mit deinen Freunden!
17 Antworten
  1. Holger says:

    Hi Jan,
    leider findet der adkOS Networkfinder zwar den Raspberry und gibt auch die IP Adresse aus (192.168.2.116), allerdings kommt eine „Nicht erreichbar“ Fehlermeldung, wenn ich im Firefox ein die Adresse http://192.168.2.116:8000/ eingebe. Was mach ich falsch? Muss ich noch irgendwelche Ports im Router (Telekom Speedport) freigeben?
    Danke für Deine Tipps,
    Holger

    Antworten
    • Jan Karres says:

      Das ist eine interne IP-Adresse. Von dem her musst du nichts freigeben. Ich würde den Raspberry Pi einfach mal neustarten und erst nach ein paar Minuten versuchen, die Adresse aufzurufen. Vielleicht braucht das System zum Starten einfach ein wenig.

      Antworten
      • Holger says:

        Vielen Dank! Ich hatte aus irgendeinem Grunde zu lange gewartet! Dann ging der Login nicht mehr… Neustart und es geht…

        Nun hab ich die folgende Unklarheit:
        Ich habe Owncloud installiert und einen Dyndns Server bei selfhost.de weist auf meinen Speedportrouter…. soweit klappt es!
        Der Port ist auch freigegeben (hab ich getestet)
        In der Owncloudinstallation habe ich als IP Adresse angegeben:
        xyz.selfhost.eu
        Nun die Frage: Wenn ich über diese IP Adresse im Browser versuche auf Owncloud zuzugreifen, kommt eine Fehlermeldung!
        Ist das zu einfach gedacht? Oder ist die IP in Owncloud eine UnterIP vom Raspberry?
        Ich hoffe ich hab mich deutlich ausgedrückt?
        Vielen Dank für Deine Antwort!
        Holger

        Antworten
        • Jan Karres says:

          Was für eine Fehlermeldung kommt den konkret? Ohne diese kann ich leider nur im Dunkeln tappen.

          Antworten
          • Holger says:

            Die normale Browsermeldung, dass z. B. „Fehler: Verbindung fehlgeschlagen

            Firefox kann keine Verbindung zu dem Server unter xyz.selfhost.eu aufbauen.

            Die Website könnte vorübergehend nicht erreichbar sein, versuchen Sie es bitte später nochmals.
            Wenn Sie auch keine andere Website aufrufen können, überprüfen Sie bitte die Daten- oder WLAN-Verbindung Ihres Geräts.“

            oder

            „Ups! Google Chrome konnte keine Verbindung zu xyz.selfhost.eu herstellen.“

          • Jan Karres says:

            Das kann mehrere Ursachen haben. Folgende Ideen sind nach Wahrscheinlichkeit geordnet:

            1. Die DynDNS Domain ist nicht richtig eingerichtet, sodass diese nicht deine aktuelle IP kennt
            2. Du hast nicht die benötigten Ports für Owncloud in deinem Router freigegeben (mindestens 80 und 443)
            3. Owncloud läuft nicht ordnungsgemäß auf dem Raspberry Pi unter arkOS. Da arkOS momentan in einer Alpha Version ist können durchaus Fehler passieren (momentan noch eher für Bastler gedacht)

  2. Andreas says:

    Hallo Jan, ich habe es fast erfolgreich installiert. Bei einem Neustart startet nginx aber nicht und ich habe keinen Zugriff auf ownCloud. Kannst du helfen?

    Antworten
    • DerT. says:

      Das gleiche Problem habe ich hier auch. Dreimal versucht zu installieren, aber nach der ownCloud-Installation lässt sich nginx nicht mehr starten. Und beim Versuch ownCloud zu deinstallieren gibt es immer eine Fehlermeldung, sodass man immer das Image neu aufspielen muss. Mein Fazit zu diesem Zeitpunkt: Die Idee hinter arkos ist gut, aber zur Zeit halt einfach noch zu „buggy“.

      Antworten
    • Jan Karres says:

      ArkOS befindet sich noch in eine Alpha Phase. Genutzt werden sollte es daher momentan nur von solchen, die sich mit der Materie auskennen und sich entsprechend selbst helfen können. Für alle Anderen empfehle ich eine ganz normale Installation von Owncloud.

      Antworten
  3. Niklas says:

    Also bei der Einrichtung von ownCloud muss ich ja eine IP-Adresse oder DynDNS Domain angeben, die aber vorher in den Settings -> Hosts registriert werden muss, was muss ich da angeben. Wenn ich da das Gleiche wie schon bei Genesis angebe, komme ich nicht mehr zu Genesis.

    Antworten
    • Jan Karres says:

      Ich möchte an dieser Stelle noch mal darauf hinweisen, dass arkOS sich in einer Alpha Phase befindet, in der visierte Benutzer damit zurecht kommen werden. Wenn du Owncloud für den Produktivbetrieb nutzen möchtest empfehle ich dir meinen Artikel Owncloud Server installieren.

      Antworten
  4. MadMax says:

    Hallo,

    ich habe die neue Version arkOs 0.7 auf mien Rasperri Pi 2 installiert (windows 8.1 mit Win32Diskimager).
    Nur habe ich das Problem, dass ich einen Router habe der als Accesspoint fungiert. Und ich nicht weiss wo ich die DynDNS einstellen soll?( Bei dem HauptModem/Router oder dem Router an dem die PCs angeschlossen sind, dann muss ich den Accesspoint leider daktiviren^^)

    Wenn ich ein neues Netzwerk über arkOs erstelle und den Pi2 neustarte komm ich auch nichtmehr auf die einloggseite.

    MFG

    Antworten
    • Jan Karres says:

      Wenn ich deine Konstruktion richtig verstehe musst du an beiden Routern die Portweiterleitung einrichten.

      Antworten
      • MadMax says:

        Also, ich habe ein Modem/(Router) der ins Internet geht, an deisem sind Telefon und der W-Lan/Lan-Router angeschlossen.

        Nur wenn ich bei dem W-Lan-Router Accesspoint aktiviert habe kann ich kein DDNS einstellen. Wenn ich den Accesspoint deaktiere kann nur 1 Pc ins Internet.

        Beim Einstellen des DDNS-Dienst bei dem HauptModem/(Router), bekomme ich eine Meldung –> Status: Unerkannter Return-Code. ().
        Ich kann auch nur den DynDNS.org dienst verwenden einen anderen kann ich nicht auswählen bzw. dieser ist fest vorgegeben.

        Sorry wenn ich mich nicht korret ausgedrückt habe, das ist schwierig zu erläutern.

        Antworten
  5. fightforprivacy says:

    Hallo, ich wollte mich nach Systemumstellung (PC) auf Linux.
    Nochmal an arkOS versuchen. Nun hab ich folgendes Problem.
    Eine MicroSDkarte habe ich mit GPartet auf FAT32 formatiert (hoffe das ist korrekt?).
    Dann die zipdatei runtergeladen, etpackt mit der konsole auf die SD-Karte kopiert.

    Es kam auch keine Fehlermeldung.

    linux-y5en:~ # dd if=/home/matt/Downloads/arkos/arkos-rp2-20150809.img of=/dev/sdc2
    4194304+0 records in
    4194304+0 records out
    2147483648 bytes (2.1 GB) copied, 243.02 s, 8.8 MB/s
    linux-y5en:~ #

    Jetzt kann ich aber den Server nicht über http://arkOS:8000 ereichen. Browsermeldung: Fehler: Server nicht gefunden

    Der Server unter arkos konnte nicht gefunden werden.
    Ich habe einen Rasbberri Pi2. Müssen beide LEDs Rot & Grün leuchten?

    Was mache ich falsch? Bitte um Hilfe.

    Antworten

Trackbacks & Pingbacks

  1. […] An dieser Stelle sei erwähnt, dass sich das Projekt zum Zeitpunkt, als dieser Artikel entstand, in einer Alpha-Phase befindet. Folglich sind einige Funktionen noch nicht implementiert und Verbesserungsideen sind in größeren Mengen zu finden. Im Folgenden werde ich meine Eindrücke der momentanen Alpha-Version vom 05. Februar 2014 schildern. Eine Anleitung dazu, wie man arkOS Alpha selbst auf dem Raspberry Pi installiert findet ihr ebenfalls in meinen Blog. […]

Antworten

Kommentar verfassen

JanKarres.de © 2007-2018